HomeForumsTechnical – GeneralCar Audio & ElectricsVT AC clutch not engaging

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of Piston 304 Piston 304 4 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #13552
    Profile photo of Zac-L67
    Zac-L67
    Participant
    Member since: April 10, 2015
    Posts: 8

    I have had my VT for a little over 12 months and the AC has never worked. I got it to start working out of all the vents instead of just the front demister but it only blows warm air. I took it to someone who said that the AC clutch isn’t engaging but I have no idea why? Anyone know if it is out of gas will it stop or is it more likely that a relay or fuse is dead?

    #13553
    Profile photo of IJ.
    IJ.
    Participant
    Member since: April 2, 2015
    Posts: 3 364
    Supporter

    Yeah either High or Low Gas pressure will stop it.

    #13558
    Profile photo of Zac-L67
    Zac-L67
    Participant
    Member since: April 10, 2015
    Posts: 8

    Is there anyway to check level?

    #18082
    Profile photo of Piston 304
    Piston 304
    Participant
    Member since: April 29, 2015
    Posts: 52

    Not that it will probably matter now.

    Chances are your refrigerant has leaked out. Pretty sure commodores dont have sight glasses. So head to somewhere that deals with a/c and get the system recovered if theres any refrigerent remaining. Then vac’d down and checked for leaks.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.